Dual Proc P-90

AST Premmia GX P90

Project: Install Linux/resurrect this retired winders server

Basic Specs

This machine is an AST Premmia GX P90. 64 Megs of simm RAM, 2.4 gig HD, SCSI CDROM, ATI Mach64 w/2megs PCI video card, embedded ethernet chip (now disabled), 3Com509B ISA nic. Known oddities include; will not boot from the hardrive, BIOS is set to read /dev/fd0 first, ISA nic will not accept configuration during install, but is detected, see /var/log/dmesg, scsi is a known oddity to me!

I've made some changes in the hardware now. See the updates below.

I've tried Mandrake8.0, (hence Mdk) Mdk SNF, RedHat7.2, Debian, and Slackware. None of those would detect and configure the ISA nic. It has to be done by hand on this machine. Now, there are two PCI slots on the riser card. The ATI video card was detected fine. Let's find some decent ISA video cards and PCI nics! Probably need to move the known card to a different slot and reboot, see if I get something different in dmesg.

UPDATE: 1-13-02 The machine is now running RedHat7.2. The kernel recognizes both cpu's. I've had to replace several parts to get to this point. I replaced the ATI video card with a noname card using a Trident chipset and one meg of vram. I can now get 800x600 8 bit display to a Cybervision C52 monitor (thanks Brian!). I replaced the floppy drive with one from a junked 386, so now there are no problems booting from the harddrive. It's now serving as my firewall/router!

UPDATE 2: 2-20-02 I've swapped some memory from the other carcass so the beast now sports 96 megs of RAM.

UPDATE 3: There's been a different box up front for a while now. By "up front" I mean working as the firewall. Currently I'm trying out SuSE version 7.2 on the old beast. SuSE does install an SMP kernel but does not get the ISA network card. It will ping itself but nothing else, yes...the card is good! I just said it works under RH!

UPDATE 4: 7-16-02 I dug up a PCI nic somewhere which is working fine. Linksys something or other (doc that Mark!). KDE runs better on this box under SuSE than on my P233 running Mdk8.1! I'm working on assembling another from the carcass.
I'm gonna paste some info from the command prompt...

mark@printman:~ > cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 5
model : 2
model name : Pentium 75 - 200
stepping : 5
cpu MHz : 89.959
fdiv_bug : no
hlt_bug : no
f00f_bug : yes
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr mce cx8 apic
bogomips : 179.40
processor : 1
vendor_id : GenuineIntel
cpu family : 5
model : 2
model name : Pentium 75 - 200
stepping : 4
cpu MHz : 89.959
fdiv_bug : no
hlt_bug : no
f00f_bug : yes
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr mce cx8 apic
bogomips : 179.81


mark@printman:~ > cat /proc/version
Linux version 2.4.4-4GB-SMP (root@SMP_X86.suse.de) (gcc version 2.95.3 20010315 (SuSE)) #1 SMP Fri May 18 20:11:27 GMT 2001
mark@printman:~ > cat /proc/meminfo
total: used: free: shared: buffers: cached:
Mem: 95862784 83906560 11956224 0 18976768 33529856
Swap: 202301440 0 202301440
MemTotal: 93616 kB
MemFree: 11676 kB
MemShared: 0 kB
Buffers: 18532 kB
Cached: 32744 kB
Active: 2836 kB
Inact_dirty: 48440 kB
Inact_clean: 0 kB
Inact_target: 4 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 93616 kB
LowFree: 11676 kB
SwapTotal: 197560 kB
SwapFree: 197560 kB


mark@printman:~ > df -kh
Filesystem Size Used Avail Use% Mounted on
/dev/hda3 2.1G 484M 1.5G 24% /
/dev/hda1 19M 3.4M 14M 19% /boot
shmfs 222M 0 222M 0% /dev/shm

That about does it. 34 processes running at the moment. I don't know what this ncsd is that only SuSE seems to use.

Update 5: October 26, 2002 Well of course I wasn't satisfied so I'm installing SuSE8.1 on the old beast. 8.1 is having trouble getting the SMP kernel installed. But I think I've figured out a way to trick it's installer.

Well, that didn't work. I tried booting from the bootdisk floppy but not putting cd1 in the drive until all the module floppies had loaded. The install insists on having the cd as soon as the scsi drivers are loaded from the modules2 floppy.

Update 6: January 2, 2003 Well I decided to stick with SuSE7.3. I also acquired a 9 gig scsi hard drive for the sparc box. So while I'm gettng NetBSD setup on the sparc this box is running my little personal website. My webserver logs show that this page is getting hits referred by google and altavista. If you're looking for help getting m$ winders running on one of these boxen, you're looking in the wrong place. I may be able to help you get a Linux distrubution running. I'm posting the output of one more command from the command prompt. It's the first few lines of the top command.

48 processes: 46 sleeping, 1 running, 0 zombie, 1 stopped
CPU0 states: 2.0% user, 1.3% system, 0.0% nice, 96.0% idle
CPU1 states: 1.0% user, 1.3% system, 0.0% nice, 97.0% idle
Mem: 93616K av, 86180K used, 7436K free, 0K shrd, 15224K buf
Swap: 197560K av, 284K used, 197276K free 27884K cached

Of note here is the low load on the system. Of course my site is not very demanding, at least not yet...

Useful Links

Just enter the model number of your AST machine and get specs...

Ari-Service


Final Update: 6-17-07 These machines, I had two, were both destroyed when my basement flooded during Hurricane Cindy in '05.


( categories: )